Seriously!

Go Back   Seriously! Forums > Serious Sam Series > Serious Sam 3

Serious Sam 3 Everything you want to know or say about Serious Sam 3!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 2 votes, 5.00 average. Display Modes
Old 12-25-2011, 02:09 PM   #1   Add To Ignore List  
Gnaar
 
Joined: Dec 2011
 
the-bright-side is offline
Default Sound: No 5.1 using Creative's "Dolby Digital Live" (PC and S/PDIF)

Hey guys, I hope you can help me. I am playing games on PC using Steam, and my external Creative X-Fi Surround 5.1 Pro sound card is connected to my home theatre system with an S/PDIF optical cable.

Serious Sam 3 is the first game I've played that insists on putting out sound in stereo. I am using Dolby Digital Live, a software by Creative that converts sound from 5.1 sources that aren't DTS or Dolby Digital 5.1 into a DD5.1 signal on the fly and sends it through the optical cable.

Here's the relevant excerpt from Sam3.log:

11:54:01 INF: Sfx API: XAudio2
11:54:01 INF: Device: SPDIF-Out (Sound Blaster X-Fi Surround 5.1 Pro)
11:54:01 INF: Mixer frequency: 48000 Hz
11:54:01 INF: Mixer voices: 2
11:54:01 INF: Max sound sources: 35
11:54:01 INF: Max total volume: 3
11:54:01 INF: Speaker config: stereo
11:54:01 INF: Environment FX: enabled
11:54:01 INF: Current environment: Padded cell

I understand that the audio detection reads Windows' sound settings. In there, the output setting is "Dolby Digital Live", not one of the 3 2-channel options available.

Is there any way I can manually configure the game's sound output? The auto detection clearly gets it wrong, and if I could force the game into 5.1, then Dolby Digital Live would automatically handle the rest.
  Reply With Quote
Old 04-29-2012, 08:28 AM   #2   Add To Ignore List  
Gnaar
 
Joined: Apr 2012
 
marco75 is offline
Question Re: Sound: No 5.1 using Creative's "Dolby Digital Live" (PC and S/PDIF)

Same problem here!

My PC specs:
CPU Intel i5 2500k
COOL Antec KÜHLER H?O 620
MOBO Gigabyte Z68XP-UD3
GPU VTX3D AMD Radeon HD6950 2GB
RAM 2 x 4 GB Corsair Vengeance DDR3
SSD 120 GB OCZ Agility 3
PSU Silverstone Strider 750 W
OS Windows 7 SP1 Home Premium

I have my PC connected to a dolby 5.1 receiver using TOSLINK (optical)
I switch the receiver to dolby digital mode.

Now it gets confusing, there are at least 3 different audio control panels on the PC:

Realtek HD Audio Manager - Select Digital Output(Optical) tab, push Dolby Digital Live button, makes it 'Default Format'

Dolby Home Theater - Has profiles for Movie, Music or Game, with Equalizer, Volume Leveler, Surround Virtualizer etc. I just use Game with default settings.

Windows Sound dialog - Has Digital Audio (HDMI), Realtek HDMI Output, Rear headphones, Internal ATAPI and Realtek Digital Output(Optical). The last one is set as Default Device.
In its Properties, I can test for
Encoded formats: DTS, DD work (WMA Pro doesn't work)
Sample rates: 44.1, 48, 96 kHz supported (192 kHz not supported)

I have a sound file called “dolby digital 5.1 test.ac3” and when I play it through Media Player Classic, it switches my receiver into DD mode and all speakers work as expected.

Relevant part from Steam\steamapps\common\serious sam 3\Log\Sam3.log:

16:58:27 INF: Sfx API: XAudio2
16:58:27 INF: Device: Realtek Digital Output(Optical) (Realtek High Definition Audio)
16:58:27 INF: Mixer frequency: 48000 Hz
16:58:27 INF: Mixer voices: 2
16:58:27 INF: Max sound sources: 35
16:58:27 INF: Max total volume: 3
16:58:27 INF: Speaker config: stereo
16:58:27 INF: Environment FX: enabled
16:58:27 INF: Current environment: Padded cell

I get no sound whatsoever from my rear speakers while playing this game. I do get them when playing source games, DVD movies, Skulltag and so on. Is there a command line switch I could try to make SS3 force surround output?
  Reply With Quote
Old 05-04-2012, 04:45 PM   #3   Add To Ignore List  
有毒物質
 
librin.so.1's Avatar
 
Joined: Aug 2011
Location: Kaunas, Lithuania
 
librin.so.1 is offline
Default Re: Sound: No 5.1 using Creative's "Dolby Digital Live" (PC and S/PDIF)

You might want to read this thread here. It is on SSHD, but it and SS3 use pretty much the same engine, so it also applies to SS3.

In short: Surround sound does not work when using XAudio2 (default). It does [sort of] work when using dsound (it can be set via the console). Yet, with it, it is very glitchy - at times, it even seems almost broken.
__________________
it just werx, fam.
  Reply With Quote
Old 05-04-2012, 08:30 PM   #4   Add To Ignore List  
Gnaar
 
Joined: Apr 2012
 
marco75 is offline
Default Re: Sound: No 5.1 using Creative's "Dolby Digital Live" (PC and S/PDIF)

Thanks for the reply, Vinska.

That's disappointing.
I get sound from my rear speakers with OpenAL, but I don't think it is true surround sound.

Something to look out for in the future -- a FPS with 3D audio that works in Vista/Seven. It is kinda like beating your head against the wall on PC -- I can get Serious Sam in Surround Sound on my Nintendo Gamecube. On my XBox 360 it is plug & play as well.

Skulltag (classic Doom open-source port) has 3D sound on my PC. ^_^

Shame, no word from Croteam. Would be good to know what audio card they tested the game on, often the sound cards simply have better drivers with more support for different APIs. But nowhere is it stated that the game supports 3D positional audio at all.
  Reply With Quote
Old 05-08-2012, 08:31 PM   #5   Add To Ignore List  
Gnaar
 
Joined: Apr 2012
 
marco75 is offline
Default Re: Sound: No 5.1 using Creative's "Dolby Digital Live" (PC and S/PDIF)

According to this thread on MSDN, the fault lies with the xaudio2_*.dll, not Serious Sam.
  Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:16 PM.